System requirements for installing jarviz mobile security

In order to use Jarviz Mobile Security in your android device, your device should support following operating systems:
Compatible operating systems: Android versions 2.2, 2.3, 2.4, 2.5, 2.6, 3.0, 4.0 or later (Eclair, Fyro, Gingerbread, Honeycomb, Ice-Cream Sandwich, Jelly Bean)